Security Advisories

This page lists all security vulnerabilities fixed in released versions of Apache Syncope.

Please note that binary patches are never provided. If you need to apply a source code patch, use the building instructions or re-generate your Maven project from published archetype.

If you want to report a vulnerability, please follow the procedure.

CVE-2018-17186: XXE on BPMN definitions

An administrator with workflow definition entitlements can use DTD to perform malicious operations, including but not limited to file read, file write, and code execution.

Severity

Medium

Affects

  • Releases prior to 2.0.11
  • Releases prior to 2.1.2

The unsupported Releases 1.2.x may be also affected.

Solution

  • 2.0.X users should upgrade to 2.0.11
  • 2.1.X users should upgrade to 2.1.2

Mitigation

Do not assign workflow definition entitlements to any administrator.

Fixed in

  • Release 2.0.11
  • Release 2.1.2

Read the full CVE advisory.

CVE-2018-17184: Stored XSS

A malicious user with enough administration entitlements can inject html-like elements containing JavaScript statements into Connector names, Report names, AnyTypeClass keys and Policy descriptions.
When another user with enough administration entitlements edits one of the Entities above via Admin Console, the injected JavaScript code is executed.

Severity

Important

Affects

  • Releases prior to 2.0.11
  • Releases prior to 2.1.2

Solution

  • 2.0.X users should upgrade to 2.0.11
  • 2.1.X users should upgrade to 2.1.2

Fixed in

  • Release 2.0.11
  • Release 2.1.2

Read the full CVE advisory.

CVE-2018-1322: Information disclosure via FIQL and ORDER BY sorting

An administrator with user search entitlements can recover sensitive security values using the fiql and orderby parameters.

Severity

Medium

Affects

  • Releases prior to 1.2.11
  • Releases prior to 2.0.8

The unsupported Releases 1.0.x, 1.1.x may be also affected.

Solution

  • Syncope 1.2.x users should upgrade to 1.2.11
  • Syncope 2.0.x users should upgrade to 2.0.8

Mitigation

Do not assign user search entitlements to any administrator.

Fixed in

  • Release 1.2.11
  • Release 2.0.8

Read the full CVE advisory.

CVE-2018-1321: Remote code execution by administrators with report and template entitlements

An administrator with report and template entitlements can use XSL Transformations (XSLT) to perform malicious operations, including but not limited to file read, file write, and code execution.

Severity

Medium

Affects

  • Releases prior to 1.2.11
  • Releases prior to 2.0.8

The unsupported Releases 1.0.x, 1.1.x may be also affected.

Solution

  • Syncope 1.2.x users should upgrade to 1.2.11
  • Syncope 2.0.x users should upgrade to 2.0.8

Mitigation

Do not assign report and template entitlements to any administrator.

Fixed in

  • Release 1.2.11
  • Release 2.0.8

Read the full CVE advisory.

CVE-2014-3503: Insecure Random implementations used to generate passwords

A password is generated for a user in Apache Syncope under certain circumstances, when no existing password is found. However, the password generation code is relying on insecure Random implementations, which means that an attacker could attempt to guess a generated password.

Affects

  • Releases 1.1.0 to 1.1.7

Fixed in

Read the full CVE advisory.

CVE-2014-0111: Remote code execution by an authenticated administrator

In the various places in which Apache Commons JEXL expressions are allowed (derived schema definition, user / group templates, connObjectLinks of resource mappings) a malicious administrator can inject Java code that can be executed remotely by the Java EE container running the Apache Syncope core.

Affects

  • Releases 1.0.0 to 1.0.8
  • Releases 1.1.0 to 1.1.6

Fixed in

Read the full CVE advisory.